All servies are down
Incident Report for Postmen
Resolved
Now the incident has been resolved and the service is fully operational.
Posted about 1 year ago. Oct 14, 2016 - 09:40 HKT
Update
We still working on the issue, will give update in next 30mins
Posted about 1 year ago. Oct 14, 2016 - 08:10 HKT
Identified
The major outage is due to our hosting provider outage.
We are working on it and will report in next 30 mins
Posted about 1 year ago. Oct 14, 2016 - 07:34 HKT
Investigating
All of our services are currently experiencing downtime.
We're investigating the cause.
Posted about 1 year ago. Oct 14, 2016 - 07:10 HKT