Secure Web Portal is down
Incident Report for Postmen
Resolved
Between 2016-08-22 14:06 UTC and 2016-08-22 14:33 UTC the Public Web Portal is down.
Now the incident has been resolved and the service is fully operational.
Posted about 1 year ago. Aug 22, 2016 - 22:38 HKT
Investigating
Our secure web portal is currently experiencing downtime.
We're investigating the cause.
Posted about 1 year ago. Aug 22, 2016 - 22:15 HKT