admin.postmen.com is down
Incident Report for AfterShip Shipping
Resolved
The issue is resolved.
Posted Apr 07, 2021 - 05:14 EDT
Investigating
It is reported that https://admin.postmen.com is failing to load. Our engineers are working in order to identify the issue.
All the users are affected.

https://secure.postmen.com is working fine.
Posted Apr 07, 2021 - 04:52 EDT
This incident affected: API (production-api.postmen.com, sandbox-api.aftership.com) and Web Portal (secure.postmen.com).