[usps-discounted] - Label generation services impacted
Incident Report for AfterShip Shipping
Resolved
The services have been fully restored by the carrier, and the incident has been resolved now.
Posted Jun 19, 2024 - 22:42 EDT
Update
According to the most recent update, the majority of labels can now be generated successfully.

We are continuing to work towards a complete resolution of this issue. We will provide regular updates on the progress.
Posted Jun 19, 2024 - 20:38 EDT
Investigating
We are currently experiencing an issue related to "usps-discounted" label generation and getting an error: "Attempted at least 2 times to courier server, they are currently unavailable. We have identified that the problem lies with the carrier and most service types are impacted.

Impacted products: Returns and Shipping

We are working on it on priority and will provide frequent updates.
Posted Jun 19, 2024 - 13:53 EDT
This incident affected: Couriers (USPS).