Issue with label generation for Canada Post
Incident Report for AfterShip Shipping
Resolved
Thank you for your patience, Canada Post service has recovered to normal. The labels can be generated successfully.
Posted Apr 20, 2023 - 10:33 EDT
Investigating
Currently Canada Post is unavailable and our users can face the issue to generate the labels.

Our team is in touch with them to get it fixed on priority. We'll keep you posted.
Posted Apr 20, 2023 - 05:33 EDT
This incident affected: Couriers (Canada Post).