Postmen USPS account Issue - Rate and label services Impacted.
Incident Report for AfterShip Shipping
Resolved
All services are now back to normal, users should be able to calculate the rates, generate labels without any issues.
Posted Nov 10, 2020 - 00:50 EST
Identified
We are experiencing an issue related to USPS labels and rate calculation being failed. The root cause has been identified and our business partner Visible SCM is working on fixing it.
Incident Time: 1:30 AM, HKT
Posted Nov 09, 2020 - 21:31 EST
This incident affected: Couriers (USPS).