[Deutsche Post DHL] issue with label generation.
Incident Report for AfterShip Shipping
Resolved
The incident has been resolved and the services are operational.
Posted May 07, 2024 - 03:07 EDT
Investigating
We have identified a failure in the label creation process for the slug dhl-germany due to an SSL certificate error.

The carrier has found the issue and the carrier is working on fixing it on their end.
Posted May 07, 2024 - 02:08 EDT
This incident affected: Couriers (DHL).