The service type dhl-germany_retoure for dhl-germany carrier is unavailable now.
Incident Report for AfterShip Shipping
Resolved
The incident has been resolved and the service is fully operational.
Posted Jul 18, 2023 - 06:14 EDT
Investigating
We are experiencing an issue in the label generation with the dhl_germany_retoure service type, we’re contacting with the carrier to fix it.
Posted Jul 18, 2023 - 03:19 EDT
This incident affected: API (production-api.postmen.com, sandbox-api.aftership.com) and Web Portal (admin.postmen.com, secure.postmen.com).