Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 15, 2023 - 18:00 EST
Scheduled
There will be planned maintenance for Royal Mail for no longer than 45 minutes in the below window. Start time - 15th November 2023 - 23:00 (GMT) End time - 15th November 2023 - 23:45 (GMT)
Please note, that customers will not be able to produce shipping & return labels or manifests within this period. Apologies for the inconvenience caused.
Posted Nov 15, 2023 - 07:58 EST
This scheduled maintenance affected: API (production-api.postmen.com) and Web Portal (admin.postmen.com, secure.postmen.com).