Postmen USPS account Issue - Rate and label services Impacted.
Incident Report for AfterShip Shipping
Resolved
This incident has been resolved.
Posted Dec 26, 2022 - 10:48 EST
Update
Our partner Maersk to identify it’s their program issue and working on a fix
Posted Dec 26, 2022 - 04:42 EST
Update
We will update you on the situation once we receive the update from the team
Posted Dec 26, 2022 - 02:50 EST
Update
We are still working on a fix for this issue with the team. Next update in an hour from now.
Posted Dec 26, 2022 - 01:47 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 26, 2022 - 00:45 EST
Update
We are continuing to work on identifying a quick fix of the issue. Next update in an hour from now.
Posted Dec 26, 2022 - 00:34 EST
Update
The problem seems to be a bit more complex than we had anticipated it to be. Our team is reaching out to our tech partner Maersk to resolve this issue at the earliest. Next update in 1 hour from now.
Posted Dec 25, 2022 - 23:24 EST
Identified
The issue has been identified and the team is working on a fix. Our fix ETA is 4 hours from now
Posted Dec 25, 2022 - 22:29 EST
Investigating
We are experiencing an issue related to USPS labels and rate calculation being failed. Our team is working on the highest priority and we will provide frequent updates.

Incident Time: 2022-12-24 00:05:03(UTC)
Posted Dec 25, 2022 - 21:58 EST
This incident affected: Web Portal (admin.postmen.com, secure.postmen.com), API (production-api.postmen.com, sandbox-api.aftership.com), and Couriers (USPS).