USPS-Ground Advantage service is unavailable
Incident Report for AfterShip Shipping
Resolved
Please use the previous shipping service First Class Package Service and Parcel Select Ground until further notice.
Posted Jul 21, 2023 - 03:20 EDT
Investigating
For the carrier USPS, the new service USPS Ground Advantage is not working. Our team is in touch with the partner to get it fixed.

Please remain to use the previously shipping service First Class Package Service and Parcel Select Ground until further notice.
Posted Jul 20, 2023 - 07:32 EDT
This incident affected: Couriers (USPS).