(canada-post) Issue with Inbound & Outbound Label Generation
Incident Report for AfterShip Shipping
Resolved
Thank you for your patience. Canada Post service is back to operational.
Posted Jun 01, 2023 - 21:50 EDT
Investigating
Canada Post service is unavailable for Inbound & Outbound label generation.

Our team is in touch with them to get it fixed on priority. We'll keep you posted with further updates.
Posted Jun 01, 2023 - 15:31 EDT
This incident affected: Couriers (Canada Post).