[usps] - Label generation services down from 9.12 23:51 HKT due to response time out.
Incident Report for AfterShip Shipping
Resolved
Services are back to normal. We appreciate your patience.
Posted Sep 11, 2023 - 15:12 EDT
Investigating
We are currently investigating this issue.
Posted Sep 11, 2023 - 12:48 EDT
This incident affected: API (production-api.postmen.com, sandbox-api.aftership.com), Web Portal (admin.postmen.com, secure.postmen.com), and Couriers (USPS).