Issue with label generation with Omni Parcel(omniparcel)
Incident Report for AfterShip Shipping
Resolved
Thank you for your patience. Omni Parcel service is back to operating normally.
Posted Jun 01, 2023 - 23:05 EDT
Investigating
Omni Parcel facing a delayed experience in generating labels due to the low error rate. For failed labels, please try to re-generate the label.

Our team is working on this and We'll keep you posted accordingly.
Posted May 30, 2023 - 00:21 EDT
This incident affected: Web Portal (admin.postmen.com).