[USPS] Discounted Label Generation Issue
Incident Report for AfterShip Shipping
Resolved
Thank you for your patience. USPS services are back to normal and labels can be generated by just re-trying the failed RMAs.
Posted Jul 10, 2023 - 10:31 EDT
Investigating
We are waiting for the carrier service to recover from their side. Our team is in touch with them to get it fixed. We'll keep you posted.
Posted Jul 10, 2023 - 07:05 EDT
This incident affected: Couriers (USPS).