The courier Ninja Van is currently unavailable and team is in touch with them to fix it.
Incident Report for AfterShip Shipping
Resolved
Thank you for your patience. The Ninja Van is back to operation now.

The incident time was from 2023-04-26 13:00 HKT to 2023-04-26 14:20 HKT
Posted Apr 26, 2023 - 03:10 EDT
Investigating
Ninja Van is currently unavailable, and this will impact our users who use this carrier for shipping.

Our team is in touch with them to get it fixed. We'll keep you posted.

We appreciate your patience.
Posted Apr 26, 2023 - 03:04 EDT
This incident affected: Web Portal (admin.postmen.com, secure.postmen.com).